main site sponsors

Mac OS X 10.11 El Capitan – Native Instruments Issues Compatibility Warning

os x el capitan

Native Instruments have issued a compatibility warning for the upcoming OS X upgrade. If you’re a Komplete, Traktor and/or a Maschine products user, or a user of some older NI hardware, you should consider these potentially serious issues before upgrading to the latest version of Mac OS X – version 10.11 El Capitan.

From NI:

Two major issues have been identified:

NI plugins do not pass the Audio Units validation in Mac OS X 10.11 – Logic Pro X affected

In Mac OS X 10.11, Native Instruments Audio Units plugins will not pass the AU validation and will therefore not be available in Logic Pro X. The root cause of this issue has been identified and a solution is currently being developed in close contact with Apple.

Incompatibility with some older NI hardware

There are compatibility issues between some older NI devices and Apple’s upcoming operating system. This issue triggers a ‘kernel panic’ – this serious problem will crash the connected computer immediately, resulting in loss of any unsaved work, or serious disruption of a performance.

The following hardware is affected:

  • TRAKTOR KONTROL S4 (MK1)
  • TRAKTOR KONTROL X1 (MK1)
  • TRAKTOR AUDIO 2 (MK1)
  • AUDIO 8 DJ
  • AUDIO 4 DJ
  • AUDIO 2 DJ
  • MASCHINE (MK1)
  • GUITAR RIG 3 (RIG KONTROL 3 hardware)

Beta Drivers

There are beta drivers already available that fix this issue. Updated drivers will be released as soon as they have been fully tested on OS X 10.11 – shortly after Apple releases OS X 10.11 to the public.

Download the beta drivers here

To keep your system working normally with the affected products, Native instruments strongly recommend waiting before upgrading your computer to OS X 10.11 El Capitan until these issues have been fully solved by either Native Instruments or Apple.

Stay up to date on all future developments regarding Mac OS X 10.11 compatibility here:

OS X 10.11 (El Capitan) Compatibility News

Related Posts:

  • Slate Digital just sent an email saying VMR has a problem with AU validation – as mentioned by Native. Slate says “don’t update to 10.11 yet”

  • Davy Drønes

    who the flip updates their main rig immediately anyways?

  • And the same warning from Arturia. It seems that AU validation is the issue on pretty much all 3rd party plugins… oops

  • Pier Luigi

    After installation of the new OS X (El Capitan) Logic Pro does not recognize Kontakt 5. Can you indicate what kind ofdrivers must be installed to solve the case?

  • Eli Krantzberg
  • Quad356

    Don’t understand how there’s still no official updates from NI to fix this issue. NI only had the El Capitan since July and were now in October, 3 months later??? NI Komplete useless with El Capitan, Way to go guy’s!!!

  • Al Future

    The 10.11.1 El Capitan release seems to sort out the Kontakt AU validation issue for me. Incidentally, I was getting the error when I was still on Yosemite. I think it was because I have XCode and the developer tools installed which were probably updated for El Capitan before I’d updated the main OS.
    So, yeah, try the new 10.11.1 release.

  • Uncle Rh!zzy4⃣

    I have El Capitan.. I wanna get Logic Pro X.. Will it work properly so I can record and make beats or nah? Lol

    • Yes!

      • Uncle Rh!zzy4⃣

        Okay Thankz! And how long does it take for the scanning audio to finish? And do I have to continue this process every time I open the app?

Follow Logic Pro Expert